New HDD O2

kubaslonka

New member
Nov 12, 2021
5
0
1
Poland, Opole
Hello guys,

So, I've installed new HDD on my O2 instead of original one and tried to install from scratch 6.5.30 and boot from it but it's impossible.
HDD is IBM 73GB SCSI ULTRA 320 10K 3,5 08K0283.
Hinv and printenv give me correct info. But when disc is under scsi(0)disk(1) cdrom don't reads disc- don't spin at all. When HDD is located under scsi(0)disk(2) then cdrom works and I'm able to use a command "boot -f dksc(0,4,8)sashARCS" and it goes to sash, but then when I use command "boot -f dksc(0,4,7)stand/fx.ARCS --x" I got info like this. I've tried to switch jumpers from "noLED" to "bit0" but no result.
Disc works normally under system. I've made a file system on it and it's mounted permanently.
I also made a folder there and put some files into.

Do you know what I'm doing wrong?

Thank you!


1.jpg
 

weblacky

Active member
Jan 13, 2020
141
37
28
Seattle, WA
So the drive info you posted doesn't give me enough to lookup the drive's manual (yeah, SCSI drives had manuals, good ones). From your description I can only think of two things (maybe 3) issues to look at to start (assuming it's not a physical issue).

Possible things to look at:
1. LVD drives are NOT SE drives (totally different signalling). LVD drives can often fall BACK to SE signalling. Your's looks to be doing that..but you'd be better off HARD SETTING the micro jumpers to SE mode..don't rely on automatic LVD/SE signaling protection. Remember the O2 is an SE Wide bus, not an LVD bus. Try hard setting the drive to be SE only clear things up more on how the drive should be operating (assumptions).

2. SCSI START COMMAND/MOTOR START. Many drives have spin-up directives to prevent power surge on tiny PSUs (back in the day). Your drive might be configured (via micro-jumpers) any number ways to ONLY start via SCSI command, delayed spin up, or immediate spin up upon power-on. I've seen SGIs properly send the drive SCSI start command. Please check what your start setting is. The reject command isn't the same as "not ready" but nonetheless, check it.

3. Parity, this becomes sort of confusing but some SGIs want parity on the SCSI devices and they ALL need it if it's to be on. So check if your drives (all of them) support a party jumper, if so...try it.

Otherwise the official description of that SCSI command is "Occurs when an inappropriate or unexpected Message Reject is received from the SCSI Adapter/A or the SCSI Adapter/A rejects a message twice..". So I'd take it as a command it doesn't understand or has already rejected before.
 

About us

  • Silicon Graphics User Group (SGUG) is a community for users, developers, and admirers of Silicon Graphics (SGI) products. We aim to be a friendly hobbyist community for discussing all aspects of SGIs, including use, software development, the IRIX Operating System, and troubleshooting, as well as facilitating hardware exchange.

User Menu