Network doesnt work in IRIX in MAME


New member
Jan 23, 2023
Good evening,
I know there's an old thread about this but unfortunately it didnt work in my case.
I installed OpenVPN, then I bridged the TAP adapter with my LAN adapter. I then start my IRIX with MAME and when the screen "Click stop for maintenance" comes up I click stop to stay in the recovery menu, then I open the MAME menu with ScrollLock and TAB and under Network there is my Local Area Network adapter showing up. Then I go back to IRIX menu, open the command window and enter "setenv -f 08:00:69:12:34:56" and "setenv monitor h" and "auto" (i dont know why I do this it was written in the tutorial on how to set up IRIX in MAME. Then IRIX boots up but gives me a warning about ethernet or bad ethernet i dont know 100%. When I login and open the browser I get errors. Netscape cant find the host. I try to enter for example but Netscape says "cant find the host". Please help me out I need a way to load files into my IRIX emulation. I already tried "chdman.exe extracthd -i myirixchd.chd -o myirixchd.hdd" also tried to extract it to .bin, .img and .raw. It extracts (converts) but I can't open these files with anything. PowerISO, WinImage, nothing works. So using network is the only way to transfer a file from my local pc to my IRIX emulation. But network also does not work please help me out I'm about to give up :(


Storybook / Retired, ex-staff
Feb 4, 2019
Mountain West (US)
If you have Discord, there was some talk in the chat about problems with MAME and OpenVPN versions working or not working with networking; two separate issues:
There are also these sites with information about SGI emulation under MAME in general:
These are just things I have seen go by; unfortunately I have not used MAME for SGI emulation so I can't really offer any first hand advice. If the problem is within IRIX and not MAME specific, people might also benefit from the output of ifconfig, the contents of /etc/resolv.conf, a routing table dump, pings to the default route, and so on for further troubleshooting.


Active member
Aug 28, 2019
If your LAN adapter is showing in MAME, it means you have the correct version of the OpenVPN TAP adapter.

Are you sure the bridge is working? Right click it and see that both network adapters are marked.

Have you set up networking in IRIX according to your LAN?

One alternative is to skip bridging, and use Internet Connection Sharing in Windows. There is an explanation how to do this in the Discord emulation channel for Sony NeWS emulation. It should apply to Irix too.
  • Like
Reactions: Elf

About us

  • Silicon Graphics User Group (SGUG) is a community for users, developers, and admirers of Silicon Graphics (SGI) products. We aim to be a friendly hobbyist community for discussing all aspects of SGIs, including use, software development, the IRIX Operating System, and troubleshooting, as well as facilitating hardware exchange.

User Menu