Getting IRIX networking up and running in MAME

Ginzanix

Member
Aug 28, 2019
26
35
13
I am certainly not a networking expert, though I thought I'd share a few tips on getting networking to work in MAME on Windows.

First you need to install OpenVPN for its TAP adapter. For some reason I could not get v2.5 to work, but 2.4.11 works fine.

Then I just bridged the TAP adapter with my LAN adapter. I believe you can alternatively use Internet Connection Sharing. When you start up MAME, press scroll lock to enable menus, and then TAB to display options. Under "Network devices" you should find your local connection, or use the left/right keys to select it. If no adapter shows up, something is probably wrong with the OpenVPN installation.

Start up IRIX, and just set it up for networking, as you would do if it was a computer on your LAN.

Downloads into the emulated Indy/Indigo2 should now work fine - i.e. simple browsing and downloading files over FTP etc. I tested this on IRIX 5.3 and 6.5 and upwards.

For some reason, however, uploading from MAME to the PC did not work if the file was above 1024 bytes or thereabout - at least in my case. The solution was to reduce the MTU, using the following command: "ifconfig ec0 mtu 1496". I only managed to make this adjustment in IRIX 6.5.22, the MTU command was not available in 6.5.7 - if someone knows the solution for earlier versions (including 5.3), that would be useful.

I'm not sure if it is due to MAME, the TAP adapter or my personal setup, but this fixed it and both uploads/downloads now work at full 10 Mbit speed (could possibly increased by looking at the MAME source).
 
  • Like
Reactions: Elf and flexion

Elf

Storybook
Feb 4, 2019
469
118
43
I'm glad the MTU fix worked :)
The root cause, if it gets discovered, will be interesting to see... Something odd going on there!
 

Ginzanix

Member
Aug 28, 2019
26
35
13
For the record, changing the MTU temporarily using "ifconfig", is only supported in later IRIX 6.5 releases, it seems.

To change the MTU in IRIX 5.3 (and I guess 6.5) permanently just change "maxethermtu" in /var/sysgen/master.d/bsd to 1496 e.g.

After this I could also upload from IRIX 5.3 to the host PC.

Still not sure if the problem is related to my setup - OpenVPN or something else... If anyone else could test out networking in Mame, that would be useful!
 
  • Like
Reactions: Elf

Ginzanix

Member
Aug 28, 2019
26
35
13
Yes - I just tested the latest source update, and can confirm it fixes the 1496 MTU issue! Now it works with 1500 MTU - i.e. transmitting from the emulated Indy works correctly without any adjustment.

Previously I tested NFS with the 1496 adjustment, and it seemed to work, though not 100% stable. I will test again after the fix.
 
  • Like
Reactions: Elf

About us

  • Silicon Graphics User Group (SGUG) is a community for users, developers, and admirers of Silicon Graphics (SGI) products. We aim to be a friendly hobbyist community for discussing all aspects of SGIs, including use, software development, the IRIX Operating System, and troubleshooting, as well as facilitating hardware exchange.

User Menu