[SGI Challenge S] ec0: ethernet cable problem

dorper

New member
Feb 22, 2021
3
0
1
I recently bought a SGI Challenge S and have been trying to install IRIX on it. However, I have been unable to connect it over Ethernet. I am able to connect the cable and the light on the rj45 jack on the router goes on indicating that it has been plugged in and connected at 10mbps. The ACT light also blinks as do all the other ports when activity occurs over the network. However, when I try to do any network operation (e.g. installing system software from network) it just prints out ec0: ethernet cable problem four times before failing saying that it could not connect to server. I have also tried connecting the cable directly to my computer and like before the light goes on and the computer recognizes being connected at 10mbps. However, it still will not work and still prints out ec0: ethernet cable problem four times before failing. Is there anyway to get the network working?
 

Elf

Storybook
Feb 4, 2019
446
113
43
For first troubleshooting steps, I would try different cables as well as cleaning the contacts on the RJ-45 jack the cable plugs into. With machines this old oxidation is likely.

It may not be either of those things, but better to get them out of the way first!
 
  • Like
Reactions: chulofiasco

dorper

New member
Feb 22, 2021
3
0
1
For first troubleshooting steps, I would try different cables as well as cleaning the contacts on the RJ-45 jack the cable plugs into. With machines this old oxidation is likely.

It may not be either of those things, but better to get them out of the way first!
Just wiped the contacts with 91% isopropyl alcohol, no corrosion was on the swab. Looking at the RJ-45 jack it does not look corroded at all. I have tried 2 three 8-wire Cat5 cables, none of them worked. Because the Challenge S is so old (10BASE-T) could it be that the pinout of the RJ45 is different? The error message is the same no matter if the cable is plugged in or not plugged in.
 

weblacky

Member
Jan 13, 2020
79
17
8
Seattle, WA
Just to make sure, lots of MODERN home stuff doesn't actually accept 10Mb ethernet anymore (won't negotiate). So the home router thing (unless it's older, it may actually not do 10Mb..after all who has it, right? Many manuals indicate this by NOT saying 1000/100/10. Or just saying 100/1000. If your documentation doesn't say 10, it won't support 10. This is a relatively new thing...but I've seen it. If you have something (like a switch) from the early 2000's that will work. They started to do this around 2010+

For the PC, if you used gigabit, it should have auto-crossed over. If you used a 10/100 card on an old PC, you need to ethernet cross-over cable (or crossover adapter).

To make sure it's working, the BEST way is to get an older desktop switch and use that as your media interface to a home router or the like.
 
  • Like
Reactions: chulofiasco

dorper

New member
Feb 22, 2021
3
0
1
Just to make sure, lots of MODERN home stuff doesn't actually accept 10Mb ethernet anymore (won't negotiate). So the home router thing (unless it's older, it may actually not do 10Mb..after all who has it, right? Many manuals indicate this by NOT saying 1000/100/10. Or just saying 100/1000. If your documentation doesn't say 10, it won't support 10. This is a relatively new thing...but I've seen it. If you have something (like a switch) from the early 2000's that will work. They started to do this around 2010+

For the PC, if you used gigabit, it should have auto-crossed over. If you used a 10/100 card on an old PC, you need to ethernet cross-over cable (or crossover adapter).

To make sure it's working, the BEST way is to get an older desktop switch and use that as your media interface to a home router or the like.
Got around to trying these things. I tried with both a standard cable and a cross over cable. Neither fixed the issue. I tried setting my NIC to 10 Mbps Half Duplex, which caused the PC to not pick up that anything was even plugged into the Ethernet port (no blinking lights). I tried to connect it to a managed switch I had laying around, it tried to auto negotiate which led it to thinking that it was connected with a 10 Mbps Half Duplex connection (the default). Looking at the port traffic, no packets were sent from the SGI and there were only 25 packets sent from the switch. Setting the port to No Auto negotiation made it unable to recognize the SGI as being plugged in to the port. Using the built-in cable tester, the cable was listed as open.

EDIT: With auto negotiation on, the switch cable tester says that the cross over cable is a normal cable of unknown length. Was able to make the switch detect the SGI cable being plugged in.
 
Last edited:

About us

  • Silicon Graphics User Group (SGUG) is a community for users, developers, and admirers of Silicon Graphics (SGI) products. We aim to be a friendly hobbyist community for discussing all aspects of SGIs, including use, software development, the IRIX Operating System, and troubleshooting, as well as facilitating hardware exchange.

User Menu