An EPIC Socket 8 Build!

Irinikus

Well-known member
Dec 16, 2019
735
550
93
South Africa
www.youtube.com
Here are the upgrades I still need to perform on this machine: (The items in red still need to be purchased!)



The Voodoo5's on its way from the UK and the card reader's on its way from the US:



I'd like to have both the Gravis Ultrasound and the Creative AWE64 Gold installed in the system so that I can compare them directly in the same system.
 

Irinikus

Well-known member
Dec 16, 2019
735
550
93
South Africa
www.youtube.com
I received the Voodoo5 5500 PCI today and it's now slotted onto the machine!







Here's the initial Quake III performance: (Just bear in mind that the RAM is still a bottleneck as I'm currently only running 192MB of RAM with Windows XP Professional installed!)

The first result running @ 800x600 @MAX Settings:





Next, the performance @ 1280x1024 @MAX Settings:





I'm pretty happy with this thus far!!! Hopefully I can get it up to 30FPS with 768MB of RAM installed!

Unreal seems to run perfectly in GLIDE, however Quake III doesn't seem to want to!!! :(

Here's Quake II @800x600:

 
Last edited:
  • Like
Reactions: doc

Irinikus

Well-known member
Dec 16, 2019
735
550
93
South Africa
www.youtube.com
Here's this machine's Quake III performance: (It should still improve once I install 768MB of EDO RAM!!!)



This is the Quake III performance achieved by various SGI's:



Not too bad for a system with a Pentium II Overdrive at its core!!! :)
 
Last edited:
  • Like
Reactions: Elf and doc

Irinikus

Well-known member
Dec 16, 2019
735
550
93
South Africa
www.youtube.com
Thanks to an input from @johnnym!!! :)

I managed to get GLIDE working by copying 3dfxOgl.dll to the game folder and renaming it to 3dfxVgl.dll!!!

Here's the new Demo four performance @ 800x600 Max settings:





Here's the new Demo four performance @ 10240x768 Max settings:





So GLIDE does offer a small performance increase!!! :)
 
  • Like
Reactions: Elf and doc

Irinikus

Well-known member
Dec 16, 2019
735
550
93
South Africa
www.youtube.com
I spent the whole day today reinstalling Windows and installing games, as the Voodoo5 and my SCSI RAID controller had an IRQ conflict (Were sharing the same IRQ) which was causing the drive to become corrupted!!!

I solved this problem by going into the BIOS and disabling the two COM ports as well as the Parallel port to free up some IRQ addresses.

I don't need to use these ports at the moment, but I can at least juggle things in the future if I need to enable one of them!
 

Irinikus

Well-known member
Dec 16, 2019
735
550
93
South Africa
www.youtube.com
The card reader came today and it's installed and works perfectly! So I now have USB!!!! :)



I have ordered the following badges for the front of the case: (they're coming via the snail mail, so it will be a long while before they arrive!)





I have removed this badge from the case and will have a badge of the same dimensions made up with "OverDrive" written on it in an appropriate font!



Now all the machine really needs is its RAM upgrade and then it will FINALLY be complete!!!
 
  • Like
Reactions: Elf and doc

Irinikus

Well-known member
Dec 16, 2019
735
550
93
South Africa
www.youtube.com
This system has been de-modded to having a Matrox G450 and two CANOPUS PURE 3D II's (Voodoo2's), as I couldn't get this graphics setup to work in my other build! (I plan to use the Voodoo5 5500 in a much more exiting and appropriate build!)

This is how it now stands: (It's now more period specific though! :) )



Here's the rear panel:



Here's the front panel:



Here's the graphics setup:



Here's the list of installed devices:



Here's the Quake II (timedemo) Performance:



These are the settings that were used:



The Voodoo2 SLI setup doesn't perform that badly when compared to the voodoo5 5500 in this system! (The Voodoo2 SLI setup obtaining an acreage of 40,8FPS in the Quake II timedemo and the Voodoo5 5500 obtaining 53FPS, making it 23%faster!)
 
Last edited:
  • Like
Reactions: Elf

Irinikus

Well-known member
Dec 16, 2019
735
550
93
South Africa
www.youtube.com
The Voodoo2's were kind of temperamental (I literally had to do a Voodoo dance to get them working each time I wanted to run Quake II!), so I swapped the Matrox Millennium G450 out with the Matrox Millennium II and the Voodoo2's are now performing perfectly!!!

It appears that they were in conflict with the G450!!!! (Maybe the AGP to PCI bridge on the G450 has something to do with this!?)

Damn, these machines are temperamental!!!! (Well all's good now :) )
 

trixster1979

New member
Sep 18, 2020
13
8
3
Loving the thread, Irinikus. Nice to see Pure3D II's as well.

As a reference, I ran Quake3 timedemo for the Four demo on my P166MMX with Miro HiScore3D 6MB Voodoo 1 (same design as a Canopus voodoo 1). It'll only manage playable 640x480 with textures set one notch down from top and low geo detail, but with these settings it gets a respectable 13.9fps. Not bad for a slow cpu and a gpu that can't multitexture.

Voodoo 1 does scale slightly, so it'd be interesting to see what maybe a 233MMX or PII might give. Quake 3 doesnt seem to benefit speedwise from the extra 2MB of texture mem the Miro has (unlike Unreal which is faster on a 6MB V1 than a 4MB one), but maybe it texture thrashes less? I shouldve tried Q3 when I had the 4MB V1 in here previously!
 
  • Like
Reactions: Irinikus

trixster1979

New member
Sep 18, 2020
13
8
3
Here's this machine's Quake III performance: (It should still improve once I install 768MB of EDO RAM!!!)



This is the Quake III performance achieved by various SGI's:



Not too bad for a system with a Pentium II Overdrive at its core!!! :)
@Irinikus I just installed a 400mhz cpu into my octane and reran the test. 22.4fps. For a moment I wondered why that was faster than the other 400mhz score on here, but I realised it’s because I’m not using standard settings, I’ve turned off stuff like 3d icons and the gun etc. so both my scores are out of kilter with your own testing. Sorry about that. But it does show that SGI q3 fps with a v8 scales almost in proportion with cpu speed, as my new results are about 25% faster than the 300. I wonder at what cpu speed a v6 or v8 would become gpu-bound?
 

trixster1979

New member
Sep 18, 2020
13
8
3
So i reset the Config to default, reran the demo and got exactly the same fps as kaigan funnily enough, so I guess you’ll need to asterisk my results to show they’re not compatible with the rest of the results! But I guess they do show that significant fps can be gained on SGI systems with a few tweaks
 

About us

  • Silicon Graphics User Group (SGUG) is a community for users, developers, and admirers of Silicon Graphics (SGI) products. We aim to be a friendly hobbyist community for discussing all aspects of SGIs, including use, software development, the IRIX Operating System, and troubleshooting, as well as facilitating hardware exchange.

User Menu